Web/desktop and sync are unavailable
Incident Report for Remember The Milk
Postmortem

An unexpected failure mode in our database, coupled with a series of unfortunate events, meant that Remember The Milk was in a (mostly) read-only mode for roughly 4 hours beginning 2024-02-01 07:49 UTC.

Due to the nature of the failure—where the website and various endpoints were up, reads were working, and writes would fail intermittently—our monitoring systems (5 independent external and internal systems) didn't alert us to the issue and continued to report that everything was fine, which led to a prolonged downtime.

We apologize for the downtime and have taken measures to ensure this scenario won't happen again.

Posted Feb 01, 2024 - 06:25 PST

Resolved
A new failure mode in our database, coupled with a series of unfortunate events, meant that Remember The Milk was in a (mostly) read-only mode for roughly 4 hours beginning 2024-02-01 07:49 UTC.

Due to the nature of the failure—where the website and various endpoints were up, reads were working, and writes would fail intermittently—our monitoring systems (5 independent external and internal systems) didn't alert us to the issue and continued to report that everything was fine, which led to a prolonged downtime.

We apologize for the downtime and have taken measures to ensure this scenario won't happen again.

Please contact our team if you continue to experience any issues.
Posted Feb 01, 2024 - 06:21 PST
Investigating
We are looking into an issue with the web/desktop app and syncing for the mobile apps. We will update with more details, and are sorry for the inconvenience.
Posted Feb 01, 2024 - 04:54 PST
This incident affected: Web Interface, Push Syncing — Android / BlackBerry 10, and Push Syncing — iOS.