Web app slowness
Incident Report for Remember The Milk
Resolved
The slowness has been resolved, and everything should be back to its usual zippy self.
Posted about 1 month ago. Apr 25, 2018 - 09:57 PDT
Investigating
Bob's currently investigating an issue that's causing the web app to be slow. We'll post as soon as we have updates.
Posted about 1 month ago. Apr 25, 2018 - 09:52 PDT