Email reminders are duplicated
Incident Report for Remember The Milk
Resolved
This incident has been resolved.
Posted Jun 02, 2024 - 15:35 PDT
Update
This issue was resolved.
Posted Jun 02, 2024 - 15:34 PDT
Investigating
We are looking into reports of reminders sending multiple times, particularly via email.

If your reminders are set to send at the top of the hour (for example "send a Daily Digest at 8:00", it may help work around this issue currently to change the time to (continuing with that example) 7:59 or 8:01 and that may help. (If you do try that, we'd be eager to hear if it does make a difference! That would help our investigation.)

If you haven't contacted us about this already, we would appreciate anyone affected to let us know so we can keep track of who is affected:

https://www.rememberthemilk.com/help/contact/?ctx=reminders

And we apologize for the inconvenience! 💙
Posted May 22, 2024 - 08:41 PDT
This incident affected: Reminders — Email.