Adding tasks by email may not be working

Incident Report for Remember The Milk

Resolved

This turned out to be an upstream issue with Mailgun that is now resolved. More details here: https://status.mailgun.com/incidents/99rdnl8bd0c5
Posted Feb 22, 2024 - 11:54 PST

Investigating

We are currently investigating this issue.
Posted Feb 22, 2024 - 08:27 PST
This incident affected: Add Tasks via Email.