Site unavailable

Incident Report for Remember The Milk

Monitoring

The data center team has mitigated the issue and the service is operational. Thank you for your patience.
Posted Apr 19, 2026 - 01:03 PDT

Investigating

The service is unavailable due to infrastructure issues. The team is investigating.
Posted Apr 18, 2026 - 23:57 PDT
This incident affects: Web Interface, API, Reminders — Email, Reminders — SMS/Text, Reminders — iOS Push Notifications, Reminders — Desktop, Reminders — Old App (All Methods), Alexa Integration, Siri Integration, Evernote Integration, Gmail Add-On, Add Tasks via Email, MilkSync for Microsoft Outlook, Push Syncing — Android, Push Syncing — iOS, and Badge Updates — iOS.