Cloudflare outage affecting Remember The Milk

Incident Report for Remember The Milk

Resolved

Cloudflare's services are back up and running normally, so the issue with our website and related services has been resolved.
Posted Nov 18, 2025 - 11:20 PST

Update

Cloudflare has now reported "The issue has been identified and a fix is being implemented." so we're hoping we see a full recovery soon.
Posted Nov 18, 2025 - 05:19 PST

Monitoring

As we posted previously, there's a widespread outage with Cloudflare that's affecting many websites.

While Cloudflare had reported that they were seeing services recover, it appears that intermittent issues are still continuing, making the Remember The Milk website and related services intermittently unavailable for some users. We'll continue to monitor this issue.
Posted Nov 18, 2025 - 05:03 PST
This incident affected: Web Interface and API.