Android app crashes for some users.
Incident Report for Remember The Milk
Resolved
4.5.20 is confirmed to have fixed these crashes.

If you left a 1 star review, please consider revising the rating... maybe? :)
Posted Mar 08, 2022 - 13:39 PST
Identified
Early indications are that version 4.5.20 (finally? hopefully?) resolves this crash for the affected users.

It should be rolling out to all users now.
Posted Mar 07, 2022 - 19:57 PST
Investigating
The Android app has had a crash that affects ~13% of users since Feb 22, 2022.

Unfortunately, we haven't been able to reproduce this crash on a variety of test devices/OS versions/etc.

The crash occurs inside the Firebase Cloud Messaging library, which is the how servers communicate with Android apps and is required for push syncing.

Due to the way the crash occurs (in a thread pool run by the FCM library), we can't catch the exception and so can't prevent the crash that way.

We have an open GitHub issue here: https://github.com/firebase/firebase-android-sdk/issues/3507

Since we're not able to repro the issue, the only way to test potential fixes is to continuously roll out new production builds to the entire installed base of the Android app and then wait for crash data to be uploaded to Google, which we're continuing to do.

Thank you for your patience.
Posted Feb 22, 2022 - 00:00 PST
This incident affected: Push Syncing — Android / BlackBerry 10.