Email reminders not working for specific people
Incident Report for
Remember The Milk
Resolved
We've identified the problem and all queued email reminders should be sent now! Sorry again for the inconvenience. 💙
Posted
Oct
05
,
2022
-
10:18
PDT
Investigating
Email reminders may not be working. If you are affected, please contact us!
https://www.rememberthemilk.com/help/contact/
Posted
Oct
05
,
2022
-
09:34
PDT
This incident affected: Reminders — Email.
×
Subscribe to Incident
Subscribe to updates for
Email reminders not working for specific people
via . You'll receive .