Web and desktop apps not loading

Incident Report for Remember The Milk

Resolved

This issue has been resolved.
Posted Apr 06, 2026 - 19:07 PDT

Monitoring

This issue has now been resolved, and we're continuing to monitor our servers. If you're still having any difficulties loading the apps, please get in touch so that we can investigate.
Posted Apr 06, 2026 - 07:18 PDT

Investigating

We're currently investigating an issue that's affecting the loading of the web and desktop apps. We'll post as soon as we have an update.
Posted Apr 06, 2026 - 06:59 PDT
This incident affected: Web Interface.