We have completed the primary data center migration.
For those who like nerdy details:
This migration includes a significant capacity increase and performance improvement across the service, as we have upgraded all our servers to the latest generation AMD EPYC Genoa series of chips (from our trusty but greying Intel Xeon Gold 6126's), data center class NVMe drives, and 25Gb interconnects.
We have also moved the service to our own ASN and /24. :)
Posted Sep 29, 2024 - 00:30 PDT
Verifying
We have completed the data center migration and are verifying operation across all services.
Posted Sep 29, 2024 - 00:06 PDT
Update
We have begun the migration process to a new primary data center. This process is expected to take around 1 hour.
Thank you for your patience!
Posted Sep 28, 2024 - 23:30 PDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 28, 2024 - 23:30 PDT
Scheduled
Remember The Milk will be unavailable for approximately one hour this weekend (see in your timezone), as we migrate our primary data center.
During the maintenance window, a Cloudflare error may be visible and is expected.
We recommend that you enable offline mode if you wish to use the Remember The Milk web and desktop apps during the maintenance window.
Android and iOS apps will automatically sync any changes once the maintenance is completed.
Posted Sep 28, 2024 - 12:29 PDT
This scheduled maintenance affected: Web Interface, API, Reminders — Email, Reminders — SMS/Text, Reminders — IM (Excluding Skype), Reminders — Skype, Reminders — iOS Push Notifications, Reminders — Desktop, Reminders — Twitter, Reminders — Old App (All Methods), Alexa Integration, Google Assistant Integration, Siri Integration, Evernote Integration, Twitter Integration, Gmail Add-On, Add Tasks via Email, MilkSync for Microsoft Outlook, Push Syncing — Android / BlackBerry 10, Push Syncing — iOS, and Badge Updates — iOS.