Some reminders are duplicating again

Incident Report for Remember The Milk

Resolved

This incident has been resolved.
Posted Feb 04, 2022 - 09:52 PST

Monitoring

We believe reminders are working as expected without duplication but we are continuing to monitor the situation. Please let us know if you experience anything unexpected with your reminders.
Posted Feb 02, 2022 - 10:54 PST

Investigating

We are looking into more reports of reminders sending multiple times. We would appreciate anyone affected to let us know if you are experiencing this:

https://www.rememberthemilk.com/help/contact/?ctx=reminders

And we apologize for this happening again! 💙
Posted Jan 28, 2022 - 10:57 PST
This incident affected: Reminders — Email, Reminders — SMS/Text, and Reminders — iOS Push Notifications.