Daily Digest email split into multiple emails for some users

Incident Report for Remember The Milk

Resolved

This incident has been resolved.
Posted Sep 24, 2026 - 05:45 PDT

Investigating

We're currently investigating an issue where some users receive multiple individual email reminders instead of one Daily Digest email. We'll post as soon as we have an update. If you're affected, apologies if you've received a bunch of email reminders in the meantime!
Posted Sep 24, 2026 - 01:51 PDT
This incident affected: Reminders — Email.