App badges may not be updating
Incident Report for Remember The Milk
Resolved
This incident has been resolved.
Posted 6 months ago. Apr 09, 2019 - 11:42 PDT
Investigating
We are currently investigating this issue.
Posted 6 months ago. Apr 09, 2019 - 08:07 PDT
This incident affected: Badge Updates — iOS.