Time zone issues for Safari users in Australia/New Zealand
Incident Report for Remember The Milk
Resolved
This incident has been resolved.
Posted almost 3 years ago. Nov 24, 2014 - 10:51 PST
Investigating
If you're seeing issues with dates and times, and you happen to be using Safari in Australia or New Zealand, unfortunately this is due to a bug in Safari. :(

We're currently investigating to see if it's possible to work around this until the bug is fixed, but in the meantime, we recommend using another browser such as Chrome.
Posted almost 3 years ago. Nov 02, 2014 - 20:22 PST