'Unexpected error' occurring when syncing with MilkSync for Microsoft Outlook
Incident Report for Remember The Milk
Resolved
This issue appears to have resolved; we believe that it was a temporary network issue. If you still experience this error, please get in touch so that we can investigate further.
Posted over 3 years ago. Jun 01, 2014 - 22:25 PDT
Investigating
We've had a number of reports from users of an 'Unexpected error' occurring when syncing with MilkSync for Microsoft Outlook. We're currently investigating this issue and will update as we have more details.
Posted over 3 years ago. Jun 01, 2014 - 20:02 PDT